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This document contains details on the new features in ImpactCAD. This document applies to only the specified 
version of ImpactCAD. 

 

What's New in Impact 2013R2 
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Overview 

This document covers the new features introduced in the 2013R2 Release of Impact.  Many of these 
features can be utilised out-of-the-box; however, several may require configuration changes, i.e., 
where an existing installation is to be upgraded.  Such features are identified throughout this 
document by an asterisk (*).  Please consult Arden Software for further details. 

3D 

 
Environment* 

Several new 3D environment options have been added – most notably allowing user-defined 
colourations for 3D Highlight Face Back, 3D Highlight Face Front, 3D Highlight Snap End, 3D 
Highlight Snap Middle and 3D Dimensions.  These items are particularly relevant in the light of the 
new 3D developments contained within this release. 
 

 

Fig 1 – New 3D colour options within Environment>Colours. 
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3D Dimensions 

The 3D>Dimensions>Dimension Objects tool has been removed.  The existing 
Draw>Dimension>Aligned tool has been extended to work within a 3D scene. 
 

 
 

Fig 2 – The Draw>Dimension>Aligned tool is now available for use within 3D scenes. 

 
The tool will provide the usual edit bar list-box containing existing Dimension Master Tool Settings, 
plus an additional Placement Snap option. 
 

 
 

Fig 3 – Edit Bar option for the Draw>Dimension>Aligned tool within a 3D scene. 
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Once the Draw>Dimension>Aligned tool has been activated, hovering the cursor over the face of a 
folding model will highlight the face.  The SHIFT key toggles between front & back faces of a panel 
and the CTRL key displays the snap-points.  
 

  

Fig 4 – Front Face & Back Face highlighting with snap points. 

 
Simply click on the required points and place the dimension in accordance with the Placement Snap 
option.  If enabled, the Placement Snap option allows the dimensions to be aligned to the 
orientation of the object (or face) being dimensioned or the current world X, Y or Z axes. Otherwise 
the dimension may be placed arbitrarily. 
 
The Help Tips on the Status Bar will update whilst the tool is in-use (‘Select the first dimension 
point’, ‘Select the second dimension point’ and lastly ‘Place the dimension’). 
 
Once a 3D dimension has been created, the 3D Scene tab of the Impact Explorer will update to show 
the dimension (as with previous Impact versions). 
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Fig 5 – Simple 3D dimensions applied to a folding model. 

 
Once a 3D dimension has been added to a scene, Terminator Style & Size, Leader Length, 
Dimension Gap & Projection Ascent, Leader, Text Position & Text Mode may all be modified via the 
Entity Inspector. 
 
The creation of a dedicated 3D Dimension Master Tool Setting (within Options>Master Tool 
Settings>General Tools>Dimension Settings) may be a worthwhile consideration.  Not all dimension 
options are available for use within a 3D scene – the Autosize, Labels & Tolerance tabs are 
unavailable, as are Angle Formatting options.  
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Note that the use of Closed Filled Arrow style terminator can give a pleasing effect within a 3D 
scene. 

 

Fig 6 – Closed Filled Arrow style terminators.     

3D Enquire 

The Enquire>Distance>2 Points tool has also been extended to work within a 3D scene. 
 
 

 

Fig 7 – The Enquire>Distance>2 Points tool is now available for use within 3D scenes. 
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The tool works identically to the Draw>Dimension>Aligned tool in that faces are highlighted by 
simply hovering the cursor over them, the SHIFT key can be used to select a back-face and the CTRL 
key will display snap-points. 
 
Note that the Help Tips on the Status Bar will update whilst the tool is in-use (‘Select the first 
enquiry point’ and ‘Select the second enquiry point’). 
 
The results will be displayed on the Edit Bar and within the Output Toolbox (Windows>Standard 
Toolboxes>Output Toolbox) as with similar 2D enquiries. 
 
 

     

Fig 8 – The results of Enquire>Distance>2 Points tool – Edit Bar & Output Toolbox. 

3D Dimension & Enquire on 3D Mesh/Solid Objects 

Both the extended tools may be used with 3D Mesh/Solid Objects – though edges on such objects 
will not feature mid-points.  The procedure for using the tools with 3D solids is identical to using the 
tools with folding models - the exceptions being that the pressing the Shift key has no effect on 3D 
solids and vertices are highlighted when the Ctrl key is pressed. 
 
 

 

Fig 9 – 3D Dimensions on an imported solid object. 
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3D Multi-Part Alignment 

A new tool 3D>Object>Align has been developed. 
 

 

Fig 10 – The new 3D>Object>Align tool 

The tool simplifies the assembly of multi-part models by providing interactive placement & rotation 
of folding models & 3D Mesh/Solid Objects.  Several features introduced by the 
Draw>Dimension>Align Dimension and Enquire>Distance>2 Points tools have been re-used, 
notably the selection of faces by hovering the cursor, the use of SHIFT to toggle between front & 
back-face highlighting and the use of CTRL to display snap-points. 
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Several Edit Bar options are available, once the tool has been activated: 
 

 

Fig 11 – Edit Bar options for the 3D>Object>Align tool – note the Angle Snap entry field. 

Group – if enabled the source object will automatically be parented to the destination object.  This 
saves time as the user no longer needs to drag & drop the objects within the 3D Scene tab of the 
Impact Explorer to create a composite model which moves & rotates as a single object. 
 
Allow Rotation – if enabled, the highlighted surface on the source object will automatically rotate to 
match the orientation of the highlighted surface on the destination object.   
 
Set Origin – if enabled, the 3D origin of the source object will be reset to the point at which it joins 
with the destination object. 
 
Angle Snap – if enabled, an entry field will be displayed allowing a value (up to 45º) to be entered.  
Free-hand object rotations will be limited to the specified increment.  
 
Note that the CTRL key must be held for the angle helper to be displayed after initially placing 
objects! 
 
 

 
 
 

Fig 12 – Front-face highlighting & snap-points on source object. 

 
 
 
 
 
 
 
 

Selection of the snap-point on the 
front-face of the source object. 
 
Only the CTRL key is used, as the snap-
point to be used is on the front-face of 
the panel. 



 Version: 1 | 14/10/2013 Arden Software Ltd 
 

 What's New in Impact 2013R2 Page 11 | 22 
 

 
 

 
 

Fig 13 – Front-face highlighting & snap-points on destination object. 

 
 

 
 

Fig 14 – Z-Axis rotation about snapped point. 

 
 

 
 

Fig 15 – Y-Axis rotation about snapped point. 

Selection of the snap-point on the 
front-face of the destination object. 
 
Again, only the CTRL key is used, as the 
snap-point to be used is on the front-
face of the panel. 

Rotation of the source object about 
the Z-axis. 
 
The rotation cursor allows the 
selection of an axis of rotation and the 
actual rotation amount. 
 
Clicking on the solid blocks of colour 
on the rotation cursor will perform 90º 
rotations. 

Rotation of the source object about 
the Y-axis. 
 
The ‘pie chart’ indicator on the 
rotation cursor provides a visual 
indication of the rotation angle. 
 
Additionally, the actual rotation angle 
is displayed on the cursor itself. 
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Fig 16 – Final placement. 

3D Rotate Object to Plane/Ground 

 

  

Fig 17 – 3D Mesh/Object before alignment to ground. 

 

 
 

Fig 18 – 3D Mesh/Object after alignment to ground. 

 
 

Source & destination objects, after 
placement & rotation. 
 

The 3D>Object>Align tool can also be used 
to quickly align 3D Mesh/Solid Objects and 
folding models to the ground or to any face 
on another 3D Mesh/Solid Object or folding 
model.   
 
Simply run the tool, hover the cursor over 
any face on the source object to highlight 
and click to pick.   
 
Repeat the process to place the object on the 
ground or any other surface. The SHIFT 
modifier (to toggle between font & back-
faces) is applicable to folding models only, 
whilst CTRL will display available snap points 
for 3D Mesh/Solid Objects as well as folding 
models. 
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3D Cross-Section 

The 3D>New>Grid tool has been modified to allow the alignment of the cross-section grid with the 
face of the bounding box of a folding model or a 3D Mesh/Solid Object.  A new Edit Bar control has 
been added (‘Bounding Box’).  If enabled, this option will allow the user to highlight a face (on a 3D 
Model/Mesh Object or a Folding Model) and the cross-section grid snap to that bounding box at that 
face.  The cross-section grid will also resize to match the extents of the bounding box.  The user can 
then manually shift the grid (either free-hand or by a fixed distance, using the Entity Inspector 
Standard Toolbox) into the required position.  If the Bounding Box option is not enabled, a user-
defined width & height may be entered and the grid snapped to a suitable point within the 3D scene 
(as with previous versions). 
 

    
 

Fig 19 – 3D>New>Grid tool – with the ‘Bounding Box’ option enabled (left) and disabled (right) 

 

Fig 20 – Aligning the bounding box with a face on a 3D Mesh/Solid Object 
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Fig 21 – The Cross-Section Grid Standard Toolbox after repositioning the grid 

An additional button has been added to the Cross-Section Standard Toolbox as shown below: 
 
 

 
 
 
 
 
 
 

Fig 22 – Before creation of ‘Bounding Box’ geometry.  Fig 23 – Additional ‘Bounding Box’ geometry. 

 
 
 
   

The button will add geometry to the cross-section, 
in the form of a bounding box matching the extents 
of the cross-section. 

 

As with previous versions, this geometry can then 
be added to a new or existing 2D layer within the 
current project.  
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Fig 24 – 3D & 2D Layers – note the bounding box geometry within the 2D layer (right). 

 
 

3D Reset Bounding Box 

This is a new Entity Inspector option, which allows the bounding box to be reset to world X, Y & Z 
coordinates, once an object has been manually re-aligned.   
 
 

 
 

Fig 25 – 3D model with bounding Box 

 

I wish to rotate the imported solid object on the 
left, so that the base is placed on the floor.  I’ll use 
the rotate to plane functionality to accomplish this.   
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Fig 26 – Rotated model & bounding box 

 
 

 
 
 
 

Fig 27 – Entity Inspector with Reset Bounding Box tool  Fig 28 – Realigned bounding box 
 

 
  

A new Reset option has been added to the 
Entity Inspector Standard Toolbox which 
will re-align the Bounding Box as shown 
below. 

The bounding box has rotated with the 
model.  Whilst I may have the model in the 
desired orientation, if I wish to use the 
Bounding Box to place a grid (in order to 
generate a cross-section), the Bounding Box 
itself may need to be re-aligned to the world 
X, Y & Z coordinates. 
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Now I can place a grid in alignment with the bounding box: 
 

 
 

Fig 29 – Grid placement on realigned bounding box 
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3D Export * 

For customers with 3D-equipped licenses who are upgrading to Impact 2013R2 from earlier 
versions, the Master Tool Settings>3D folders 3D Export Settings and VRML Settings (and their 
contents) will be completely removed once they have upgraded to Impact 2013 R2.   
 
These folders contained settings for 3D exports to the 3D Studio Binary (*.3ds) and VRML 2.0 (*.wrl) 
formats.  The settings will need to be recreated (once the upgrade has taken place) in a new Master 
Tool Settings>3D folder named 3D Import/Export Settings.   
 
If in doubt, print these Master Tool Settings to a text file prior to the upgrade:  
 

 

Fig 30 – Print-to-File for VRML Export Master Tool Settings prior to upgrading to Impact 2013 R2 

Use the details contained within the text file to re-build those settings within the new 3D 
Import/Export Settings folder.  Note that settings exported from earlier versions of Impact will not 
be able to be imported into Impact 2013R2! 
 
The new 3D Import/Export settings will function much in the same way as their 2D counterpart, 
whereby an export setting has a branch for each supported format (though at the moment, the 
majority of those branches are unused). 
 
 
The following screenshots illustrate the 3D Studio Binary and VRML 2.0 export branches of the new 
Master Tool Setting – the available options are identical to all Impact versions post 4.1.  
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Fig 31 – 3D Studio Export branch of the new 3D Import/Export Master Tool Setting 

 

Fig 32 – VRML 2.0 Export branch of the new 3D Import/Export Master Tool Setting 
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3D Import* 

Customers with 3D-equipped licenses will now be presented with some additional options when 
they import 3D Mesh/Solid Objects.  Objects may be imported into the current project & layer (if 
applicable), to a new layer in the current project or to a new project altogether.  These options are 
available from the Import File dialog and also within the 3D Import/Export Master Tool Setting. 
 
 

 

Fig 33 – New options within the Import File dialog box 

 

Fig 34 – Options may be configured as part of a 3D Import/Export Master Tool Setting 
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3DX Import* 

For customers with 3DX-equipped licenses, the upgrade to Impact 2013R2 brings several additional 
features, which may be accessed via the 3D Import/Export Master Tool Setting (and also via the File 
Import dialog as a temporary override). 

 

Fig 35 – 3DX Import options 

 
Centre objects at the origin – if enabled, the centre of the model will be positioned at the centre of 
an Impact 3D scene (X,Y & Z = 0.00mm,0.0mm & 0.0mm) .  If this option is not enabled, the model’s 
own origin will be used and positioned at the centre of an Impact 3D scene. 
 
Import object hierarchy – if the 3DX model contains a hierarchy (a collection of related parts and 
sub-parts) and this option is enabled, the hierarchy of parts & sub-parts will be preserved. If the 
option is disabled, the resultant model will be a comprised of a single object.  This option is 
analogous to the 2D importing of a drawing containing Blocks & Sub-Blocks without exploding them. 
 
Group objects together – if the hierarchy has been imported and this option has been enabled, 
hierarchies and sub-parts within a model may be selected, but not translated unless they are 
manually un-parented (removed from the hierarchy).  If this option is disabled, hierarchies & sub-
parts may be selected & translated, without any need for un-parenting.  Disabling this option is 
analogous to the 2D recursive exploding of Blocks.  
 
Import hidden objects – if the model contains objects marked as hidden or invisible in the 
originating application, this option will allow the import of those objects. 
 
Make all objects visible - all objects within the model will be made visible, regardless of their status 
in the originating application. 
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Surface Quality – choose from extra low, low, medium, high & extra high.  This affects the number 
of polygons & vertices which are created for the model (or each sub-part, if a hierarchy is imported).  
The more polygons & vertices, the smoother the model (or sub-part) appears, albeit at a cost of 
increased import-time & memory usage.  The Surface Quality option is analogous to the curve 
tolerance control found within the 3D Wizard. 
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